Welcome, Guest
Username: Password: Remember me
Default product support category.
  • Page:
  • 1

TOPIC: Virtuemart thumbnail image not working after uploa

Virtuemart thumbnail image not working after uploa 2 years 10 months ago #203

  • alexr451
  • alexr451's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I have recently done a bulk upload to my Virtuemart store using 'VM CSV ultimate which went fine except that none of my thumbnail images are showing up, the main image on the product page is showing up just fine but the thumbnail will not.

I am using externally hosting images from Doba so am just putting the image URL into the CSV file.

So it seems it is having a hard time generating the thumb from the external URL.

When I go the products in VM backend to edit them it has the following red error message at the top.

"Error vmError: Couldnt create thumb, file not found /home/lancotools/public_html/htt p://images.doba.com/products/441/D_Bfly_CZNSW26945Q_mar_detailed_image_1.jpg"

So it seems it is looking in Joomla directory for the complete image path which will obviously never be there.

When I inspect the element on the published site in the product category here is what is showing for src for the thumb alpina.websitewelcome.com/~lancotools/co...ral/filetype_jpg.png

Which there is nothing there

Note: there is just one product image url that is being used for both thumb and full image. I am also uploading a few thousand image so I can't do anything manually for each image.

So I need a way to get virtuemart to just simply pull the thumb image from the external url like it did for the main product image and not try to generate it or look in the the local directory for it.

Things I have tried

I have tried disabling Dynmaic thumbnail re-sizing

I have tried entering and not entering the CSV column "product_thumbnail_1" in hopes that just the main image column will be enough. But the outcome is the same either way.

I have tried going into VM configuration and changing the "Product Media URL" and the "Thumbnail url for media to sell" path to the first part of the external url example: images.doba.com/products/ then only filling the CSV with actual file name but that doesn't work either.

I have been working on this for 2 days and I'm getting desperate any ideas or suggestions would be much appreciated.

Thanks!!
The administrator has disabled public write access.

Virtuemart thumbnail image not working after uploa 2 years 10 months ago #204

  • ekerner
  • ekerner's Avatar
  • OFFLINE
  • Administrator
  • Posts: 240
  • Thank you received: 24
  • Karma: 2
You or I need to have a look at your database to determine if the error belongs to VMPCSV or VM.

Like
SELECT virtuemart_media_id, file_url FROM <prefix>virtuemart_medias WHERE file_url LIKE '%http%';

If you need me to take a look please send db access (like ssh/phpMyadmin/etc) to support at ekerner.com

Thanks.
The administrator has disabled public write access.

Virtuemart thumbnail image not working after uploa 2 years 10 months ago #205

  • alexr451
  • alexr451's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Okay thank you very much. I have sent you the cpanal login info. The email will come from This email address is being protected from spambots. You need JavaScript enabled to view it.

Thanks!
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.183 seconds

Receive Product Updates

Logged in members may subscribe to receive product updates. LOGIN

Select Currency

Featured Products

Contact Us

Call us at:
+61 415 607 770

Email us at:
shop@ekerner.com

Leave us feedback:
Feedback Form

Message Us:
Enquiry Form

facebook

twitter

rss